20240320 通达信“杀庄回马枪”主图指标选股公式--转强区间

时间:2024-06-06 18:50 点击:168

欧欧 欧欧量化 2024-03-20 08:01 广西

图片

一、主图公式如下:

DRAWTEXT_FIX(1,0.005,0,0,'所属风格:'),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0,0,FGBLOCK),COLORYELLOW;DRAWTEXT_FIX(1,0.005,0.05,0,'所属概念:'),COLORMAGENTA;DRAWTEXT_FIX(1,0.06,0.05,0,GNBLOCK),COLORYELLOW;CTA3:=IF(1,(C/REF(C,1)-1)*100>9.5,0),NODRAW;最后涨停距今数:BARSLAST(CTA3),NODRAW,COLOR00CCCC;CTA4:=(REF(C,BARSLAST(CTA3))+REF(OPEN,BARSLAST(CTA3)))/2;STICKLINE(C,CTA4,REF(LOW,BARSLAST(CTA3)),4,0),COLOR002828;DRAWKLINE(HIGH,OPEN,LOW,C);STICKLINE(CTA3,OPEN,C,2.6,0),COLOR0000E5;STICKLINE(CTA3,OPEN,C,2.4,0),COLOR335555;STICKLINE(CTA3,OPEN,C,1.8,0),COLOR338888;STICKLINE(CTA3,OPEN,C,1.2,0),COLOR33AAAA;STICKLINE(CTA3,OPEN,C,0.6,0),COLOR33CCCC;STICKLINE(CTA3,OPEN,C,0.1,0),COLOR33EEEE;CTA5:=REF(C,1);CTA6:=IF((CTA5-C)*100/CTA5>=10-0.01*100/CTA5,1,0);STICKLINE(CTA6,OPEN,C,2.6,0),COLORE50000;MA13:MA(C,13),COLORCYAN;IF(MA13>REF(MA13,1),MA13,DRAWNULL),COLORRED;MA21:MA(C,21),COLOR00CCCC,LINETHICK2;CTA7:=C>MA21 AND MA13>REF(MA13,1) AND CTA6!=1;CTA8:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;CTA9:=REF(C,1);CTA10:=SMA(MAX(C-CTA9,0),2,1)/SMA(ABS(C-CTA9),2,1)*100;CTA11:=SMA(MAX(C-CTA9,0),14,1)/SMA(ABS(C-CTA9),14,1)*100;CTA12:=45;CTA13:=80;CTA14:=20;CTA15:=5;CTA16:=CTA10< CTA12 AND REF(CTA10,1)>CTA12;CTA17:=CTA10< CTA14 AND REF(CTA10,1)>CTA14;CTA18:=COUNT(CTA3,13)>=1;CTA19:=SMA(LOW,4,3);CTA20:=CTA16 OR CTA17 AND CTA18;CTA21:=REF(CTA16,1) OR REF(CTA17,1) AND LOW< MA(C,5) AND CTA18 AND CTA7 AND C>REF(LOW,BARSLAST(CTA3));STICKLINE(CTA20 AND NOT(CTA3),OPEN,C,2.4,0),COLOR550055;STICKLINE(CTA20 AND NOT(CTA3),OPEN,C,1.8,0),COLOR880088;STICKLINE(CTA20 AND NOT(CTA3),OPEN,C,1.2,0),COLORAA00AA;STICKLINE(CTA20 AND NOT(CTA3),OPEN,C,0.6,0),COLORCC00CC;STICKLINE(CTA20,OPEN,C,0.1,0),COLOREE00EE;STICKLINE(CTA21 AND NOT(CTA3),OPEN,C,1.2,0),COLOR000088;STICKLINE(CTA21 AND NOT(CTA3),OPEN,C,0.6,0),COLOR0000AA;STICKLINE(CTA21 AND NOT(CTA3),OPEN,C,0.3,0),COLOR0000CC;STICKLINE(CTA21,OPEN,C,0.1,0),COLOR0000EE;STICKLINE(CTA21,CTA19*0.995,CTA19,5,0),COLORGREEN;DRAWTEXT_FIX(C>O,0,0.9,0,'微信公众号:欧欧量化'),COLOR0000FF;DRAWICON(CTA21,LOW*0.98,1);CTA22:=AMOUNT/VOL/100;CTA23:=REF(C,1);STICKLINE(CURRBARSCOUNT< 21 AND CTA3=1,CTA22,CTA22,2.5,0),COLORYELLOW;STICKLINE(C,CTA4,CTA4,2,0),COLORRED;STICKLINE(C,REF(LOW,BARSLAST(CTA3)),REF(LOW,BARSLAST(CTA3)),2,0),COLORCCCC00;

二、选股公式:

CTA3:=IF(1,(C/REF(C,1)-1)*100>9.5,0),NODRAW;CTA4:=(REF(C,BARSLAST(CTA3))+REF(OPEN,BARSLAST(CTA3)))/2;CTA5:=REF(C,1);CTA6:=IF((CTA5-C)*100/CTA5>=10-0.01*100/CTA5,1,0);MA13:=MA(C,13),COLORCYAN;MA21:=MA(C,21),COLOR00CCCC,LINETHICK2;CTA7:=C>MA21 AND MA13>REF(MA13,1) AND CTA6!=1;CTA8:=(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4;CTA9:=REF(C,1);CTA10:=SMA(MAX(C-CTA9,0),2,1)/SMA(Abs(C-CTA9),2,1)*100;CTA11:=SMA(MAX(C-CTA9,0),14,1)/SMA(ABS(C-CTA9),14,1)*100;CTA12:=45;CTA13:=80;CTA14:=20;CTA15:=5;CTA16:=CTA10< CTA12 AND REF(CTA10,1)>CTA12;CTA17:=CTA10< CTA14 AND REF(CTA10,1)>CTA14;CTA18:=COUNT(CTA3,13)>=1;CTA19:=SMA(LOW,4,3);CTA20:=CTA16 OR CTA17 AND CTA18;CTA21:=REF(CTA16,1) OR REF(CTA17,1) AND LOW< MA(C,5) AND CTA18 AND CTA7 AND C>REF(LOW,BARSLAST(CTA3));红箭头:CTA21;

风险提示:本指标公式仅作为知识分享,模拟测试不构成任何投资建议,不作投资依据。

图片

END

图片

本站仅提供存储服务,所有内容均由用户发布,如发现有害或侵权内容,请点击举报。
当前网址:http://www.zszcapp.com/zhengguidegupiaogongganpingtai/4151.html
tag:20240320,达信,杀庄回马枪,主图,指标
发表评论 (168人查看0条评论)
请自觉遵守互联网相关的政策法规,严禁发布色情、暴力、反动的言论。
昵称:
最新评论

Powered by 联华证券_正规的股票杠杆平台_最安全的杠杆炒股平台 @2014 RSS地图 HTML地图

Copyright 365建站 © 2014-2024 联华证券 版权所有